Rješenje: Aplikacija na računalu treba .NET Framework 3.5

Rješenje: Aplikacija na računalu treba .NET Framework 3.5

Fix App Your Pc Needs

Ako koristite Windows 8 ili 10, vjerojatno ste primijetili skočni prozor koji treba da instalirate .NET framework 3.5. Skočni prozori mogu biti nasumični ako pokrećete programe u pozadini ili prilikom pokretanja. Skočni prozor kaže:



'Za aplikaciju na računalu potrebna je sljedeća značajka sustava Windows: .NET Framework 3.5 (uključuje Net 2.0 i 3.0)'



Skočni prozor obično je originalan, ali ga može pokrenuti bilo koji program kojem je potreban ovaj okvir, uključujući zlonamjerni softver. Ako odlučite preskočiti instalaciju, skočni će se prozor možda ponovno pojaviti kada pokušate instalirati program ili kada pokušate pokrenuti određeni program. Međutim, preuzimanje s Interneta i instaliranje na vaše računalo vratit će samo frustrirajuću pogrešku što je okvir već instaliran. Ovaj će članak objasniti zašto se pojavljuje ovaj skočni prozor, što je .NET framework i zašto je potreban na vašem računalu. U konačnici, dat ćemo vam metode kako možete instalirati .NET Framework 3.5 na svoje računalo.



Da bismo razumjeli zašto je potreban .NET framework 3.5 i zašto se ovaj zahtjev pojavljuje, prvo moramo razumjeti što je .NET framework. U programiranju, okvir je zbirka sučelja za programiranje aplikacija (API-ja) koja su obično zajednička biblioteka kodova koju programeri mogu nazvati prilikom razvijanja aplikacija. Na taj način, oni ne moraju sami pisati kôd, štedeći dragocjeno vrijeme i stoga potičući programera da se više usredotoči na ono što program može učiniti. U .NET Framework ta se biblioteka zajedničkog koda naziva Framework Class Library (FCL). Kodovi u zajedničkoj biblioteci mogu izvoditi sve vrste različitih funkcija, a takvih je tisuća. Na primjer, kôd za pinganje drugog uređaja na mreži ili kôd za uključivanje dijaloškog okvira 'Otvori kao' ili 'Spremi kao' smješten je u ovaj okvir.

Uz standardizirane kodove .NET Framework pruža i runtime okruženje za pokretanje aplikacija koje su izrađene pomoću framework kodova. Runtime okruženje je vrsta pješčanika u kojem se pokreću aplikacije; ista stvar koja se događa s Java aplikacijama. Izvršno okruženje .NET nazvano je Common Language Runtime (CLR). CLR također upravlja memorijskim i procesorskim nitima, obrađuje iznimke programa i upravlja sigurnošću. Sastavljanjem kodova prije njihovog pokretanja, runtime okruženje izolira softver od računalnog hardvera, osiguravajući tako kodirani program na bilo kojem računalu.

.NET framework razvijen je za nekoliko operativnih sustava, ali zbog svoje vlasničke prirode uglavnom se koristi na Windowsima. Bilo je nekoliko verzija .NET framework-a. Početna ideja bila je da su novije verzije unatrag kompatibilne sa kodovima izrađenim pomoću starijih verzija. Međutim, shvatilo se da to više ne može biti slučaj. Međutim, .NET Framework verzija 3.5 sadrži kodove iz verzije 3.0 i verzije 2.0 stoga je unatrag kompatibilna samo s tim verzijama. Najnovija verzija (V. 4.6) nije kompatibilna s unatrag i stoga se obično koristi zajedno s drugim verzijama.



Što uzrokuje .NET framework 3.5 potreban je skočni prozor u sustavu Windows 8/10

Windows 8 i Windows 10 obično se isporučuju s .NET Framework verzija 3.5 i 4.6. Međutim, uključena je samo verzija 4.6 i morat ćete uključiti .NET Framework 3.5. Stoga će svi programi koji koriste okvir .NET verzije 3.5 pokrenuti skočni prozor koji treba instalirati .NET Framework 3.5 jer verzija 4.6 nije kompatibilna s unatrag. Brojni su programi izrađeni pomoću ovog okvira jer podržava programe kodirane u C #, C ++, F #, Visual Basic i nekoliko desetaka drugih. U želji da potakne upotrebu nove verzije, stariji .NET framework 3.5 je stoga onemogućen na vašem računalu. Međutim, neki programeri distribuiraju potrebnu verziju sa svojim programima.

Ako na računalu dobijete pogrešku koja kaže da je .NET verzija 3.5 potrebna za pokretanje programa, upotrijebite donje metode da biste ga instalirali na računalo. .NET framework 3.5 uključuje verzije 3.0 i 2.0 i stoga će riješiti skočne prozore koji traže da instalirate verzije 3.0 i 2.0.

1. metoda: Uključite .NET Framework 3.5 u programe i značajke

Srećom, .NET framework 3.5 isporučuje se sa sustavom Windows 8 ili 10. Sve što trebate jest uključiti ga i omogućiti da ga koriste programi koji ga zovu. Zbog toga će instalacija preuzetog .NET Framework-a jednostavno navesti da je verzija koju pokušavate instalirati već na vašem računalu. Da biste uključili ovu značajku:

  1. Pritisnite Windows ključ + R do otvorenog trčanja
  2. Tip appwiz.cpl u okvir za pokretanje i pritisnite Enter da biste otvorili prozor s programima i značajkama
  3. Kliknite vezu “ Uključite ili isključite značajke sustava Windows '.
  4. Tražiti ' .NET Framework 3.5 (uključuje .NET 2.0 i 3.0) '
  5. Označite okvir s lijeve strane i kliknite U redu da biste uključili .NET Framework 3.5.
  6. Ponovno pokrenite računalo ako se to zatraži.

2. metoda: Instalirajte i omogućite .NET Framework 3.5 pomoću DISM-a

Korištenjem alata za naredbene retke Deployment Image Servicing and Management (DISM) možete instalirati i aktivirati .NET framework 3.5 na svoje računalo. Za to će vam trebati Windows 8/10 DVD ili ISO datoteka.

  1. Umetnite DVD u ladicu i zatvorite ga ili kliknite desnu tipku miša na .ISO datoteku i odaberite ‘mount’; ISO datoteka će se učitati kao virtualni disk / pogon (imajte na umu slovo ovog pogona).
  2. Pritisnite Windows tipku + R da biste otvorili prozor za pokretanje
  3. Utipkajte CMD u okvir za pokretanje i pritisnite Enter da biste otvorili naredbeni redak
  4. Upišite ili zalijepite naredbu ispod u svoj CMD prozor:

    DISM / Online / Enable-Feature / FeatureName: NetFx3 / All / LimitAccess / Izvor: D: sources sxs

  5. Gdje je D: put do vaših instalacijskih datoteka za Windows (DVD ili virtualni pogon).
  6. Pričekajte da instalacija završi uspješno
  7. Ponovno pokrenite računalo ako se to zatraži.

Također možete pogledati moj drugi članak koji objašnjava kako Vratite se na .NET Framework 3.5

4 minute čitanja